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Overview
 

Perspective Workflow™ is a business activity monitoring application that works behind the scenes 

to help you stay on top of Perspective’s reported incidents, ongoing investigations and current 

assignments. It monitors and auto-responds to critical, time-sensitive data, automatically notifying 

the necessary personnel and guiding team members through the proper processes and protocols.  

To get Perspective Workflow up and running, please follow the instructions provided throughout 

this guide, in order of appearance. 

Minimum System Requirements 

Web Services Server 

Available Disk Space† 

 1 GB 

Processor Speed 

 Minimum: 2 GHz 

 Recommended: 3 GHz+ 

Memory 

 Minimum: 1 GB 

 Recommended: 2.5 GB+ 

Operating System 

 Minimum: Windows Server® 2003 with SP 1 

 Recommended: Windows Server 2003 with SP 2 

.NET Framework 

 Version 3.5 SP 1 

IIS (Internet Information Services) 

 IIS 6.0, WSE 3.0 

                                                      
 This document is only applicable to organizations that have purchased Perspective Workflow, 

an optional module for Perspective by PPM. If you are not certain that your Perspective system 

includes Workflow, please contact Customer Service for verification. 

† Depending on the size of your Perspective database, more disk space may be required. 
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Database Setup 
The Perspective Workflow database setup procedure depends on what version of Perspective 

your organization is using and whether the Workflow setup is new or existing. Refer to the 

procedure below to correctly setup your database. 

New Workflow Setup – Perspective 4.0 and Greater 

Follow this procedure if setting up Workflow for the first time and using Perspective 4.0 and 

greater. 

1. Open Microsoft® SQL Server® Management Studio.  

2. Run the database views script PWFDataViews_v2.0.sql against the Perspective database 

being used with Perspective Workflow. 
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ODBC Connection Setup 
1. Select Start > Administrative Tools > Data Sources (ODBC). 

 

Note: Perspective Workflow uses the 32 bit ODBC manager regardless of whether you are 

running Workflow on a 32 bit or 64 bit machine. On 64 bit machines, the 32 bit ODBC device 

manager is typically located in the %winDrive/Windows/syswow64 directory and can be run 

by executing ODBCAD32.exe. 

2. Select the System DSN tab and click Add. 

 

3. Select SQL Server and click Finish. 
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4. Enter a Name and Description for the ODBC connection; select the name of the SQL 

server that hosts your Perspective database; and click Next. 

 

5. Choose the authentication mode you want to use for the ODBC connection (Windows 

authentication or SQL authentication), and click Next. 
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6. Select the Change the default database to box and choose the name of your Perspective 

database from the list below.  

 

 

7. Ensure the Use ANSI quoted identifiers and Use ANSI nulls, paddings and warnings 

boxes are selected, and click Next. 

8. Click Finish. 
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9. Click Test Data Source. 

 

 

10. When the data source connectivity test is complete, click OK. 
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Perspective Workflow Installation 
1. Double-click the PW_Setup_V82d.msi file located inside the Installation Files v1.0 folder; 

then click Run. 

 

 

 

 

2. Click Next. 
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3. Select the I accept the license agreement radio button, and click Next. 
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4. Read the installation information, and click Next to begin the install. 

  

5. Enter your user information, and click Next. 
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6. The default install destination will be displayed. (If a different location is preferred, use the 

Browse button to navigate to the chosen location.) Click Next. 
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7. Accept the default settings for all components by clicking Next.  

 

Note: Remote Perspective Workflow clients must be individually licensed in order to run the 

Workflow application. If you install one or more remote Perspective Workflow clients, you 

must only install the core and client components on each remote client. You will not need to 

specify the location of the Workflow database during the installation process; the first time 

that a remote client is executed, the user will receive a browse button allowing them to 

locate the Workflow database. 
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8. Click Next to begin the installation. 

 

 

Note: The service needs to run using an account that has local admin rights to the server 

where workflow is installed. 
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9. If prompted to confirm the installation, click Yes. 
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10. Click Finish once the installation is complete. 
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11. Open Windows Explorer. 

12. Navigate to the destination folder. 

Note: The default location is C:\Program Files\PPM 2000 Inc\PerspectiveWorkflow\ 

13. Select the bin folder.  

14. For each of the following executables (ks_admin.exe, ks_event.exe, ks_mon.exe, 

ks_serv.exe), right-click, select Properties, the Compatibility tab, Change settings for all 

users button, and finally, select Run this program as an administrator. Click OK. Click OK. 
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IM Installation  
There are two IM installations: IM32 (for 32 bit machines), and IM64 (for 64 bit machines). As IM 

is optional, only install it if you will use it. 

The IM Accounts option enables you to configure and maintain the Instant Message accounts 

from which you will send notifications. Note that you can configure multiple IM accounts using 

multiple IM methods, such as Windows Live Messenger, Google Talk, and ICQ, so that you can 

receive IM alerts via one method while at work and via a different method while at home. 

It is suggested that prior to setting up this account that you send IM “invitations” to all the 

recipients. Note that some IM providers (e.g., Windows Live Messenger) requires an IM recipient 

to “accept” invitations from an account before the messages can be successfully delivered, 

whereas other IM providers (e.g., ICQ) require “invitations” but do not require recipient 

acceptance. 

1. Double-click the IM.msi or IM64.msi (32 bit or 64 bit) file located inside the Installation 

Files v1.0 folder; then click Run. 
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Licensing & Server Login Information 

1. Open the Perspective Workflow Administrator. The application can generally be accessed 

through Start > Programs > Perspective Workflow > Administrator. 

2. In the logon window, enter your administrator User Name and Password, then click OK. 

(The default User Name is Admin and the default Password is master.) 

  

3. Under the Help menu, select About Perspective Workflow Administrator. 

 

4. Click the License button. 
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5. Enter the license information provided to you by PPM 2000 and click OK, then OK again. 

 

6. Click the Server Login Information button on the toolbar. 

 

7. Enter your administrator User Name and Password, then click OK. (The default User Name 

is Admin and the default Password is master.) 

 

Note: If the fields are pre-populated, delete the values and re-enter your login information. 

 

8. Close the Perspective Workflow Administrator; then, start the Perspective Workflow service 

in Computer Management. 
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Email Setup 
1. Open the Perspective Workflow Administrator. The application can generally be accessed 

through Start > Programs > Perspective Workflow > Administrator. 

2. In the logon window, enter your administrator User Name and Password, then click OK. 

(The default User Name is Admin and the default Password is master.) 

 

3. Expand the Software Setup node, click Email Accounts and click the New Email Account 

button in the top-left corner of the window. 

 

4. Select INTERNET for the Email Type field; populate the Email Account Description, 

Outgoing Mail (SMTP) Server Name and SMTP From Name fields (the SMTP From 

Name field must be populated with a valid email address); ensure that the Active box is 

checked; and click Save and Close.  

 

Note: You must create a separate Perspective Workflow email account for each email 

address that you want email notifications to be delivered from. For instance, if you would like 

employees in different departments to receive email notifications from different email 
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accounts, you must create a Perspective Workflow email account for each department. 

(Keep in mind that each event can only use one email account to send notifications from.) 

 

5. Close the Perspective Workflow Administrator. 

IM Setup 
1. Open the Perspective Workflow Administrator. The application can generally be accessed 

through Start > Programs > Perspective Workflow > Administrator. 

2. In the logon window, enter your administrator User Name and Password, then click OK. 

(The default User Name is Admin and the default Password is master.) 
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3. Expand the Software Setup node, click IM Accounts. 

 

4. Service Provider: Select from Windows Live Messenger, Google Talk, Yahoo! Messenger, 

and ICQ. 

Account Description: A description of the account that will be used for sending IM 

notifications. 

Username: The user name for this IM account. Note that different IM methods (such as 

Windows Live Messenger and ICQ) require different types of login information. Typically, 

Windows Live Messenger uses an email address whereas ICQ uses a unique numeric 

identifier. Please refer to the documentation/help text for your preferred IM provider for 

details. 

Password: The password of this IM account. 

Active: Whether this account is currently available for sending IM alerts (you can configure 

an account without enabling it for immediate use) 

Note: Each IM alert message may not exceed 1,500 characters (including spaces) in length. 
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Perspective Workflow Event Pak Installation 

1. Open the Perspective Workflow Event Manager. The application can generally be accessed 

through Start > Programs > Perspective Workflow > Event Manager. 

2. In the logon window, enter your administrator User Name and Password, then click OK. 

(The default User Name is Admin and the default Password is master.) 

 

   

3. Under the File menu, select Event Pak then click Install. 

  

4. Browse to the location of the PerspectiveWorkflowEventPak_v2.0.kse file (included in the 

Event Pak folder); then, click Open. 
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5. Click Install. 

 

6. When the Finished message appears at the bottom of the window, click Close. 

 

7. Select one of the Standard Event Paks under Application Events. 

8. Click the Properties button to bring up the database connection window. 
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9. Delete all connections that currently exist by selecting them, clicking Edit Connection, and 

Delete. 

 

10. With Perspective Connection selected in the Connection to Use For Database Access 

field, click the Edit Connection button. 

  

11. In the ODBC Data Source Name (DSN) field, select the ODBC connection that you created 

in the ODBC Connection Setup phase of this installation process; click Save and Close; 

and then click OK.  

 

Note: If SQL authentication was used for the ODBC connection, you must also enter your 

SQL credentials in the Username and Password fields. These will be the same credentials 

that Perspective uses to connect to the database, not the username and password used to 

get into Perspective. 
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Subscriber Configuration 

In Perspective Workflow, individuals who receive email notifications when events are triggered 

are known as "subscribers." Each event must have one or more subscribers associated with it, 

but before you can choose subscribers for each of your events, you must either manually create 

subscriber records within Perspective Workflow or link user records in your Perspective database 

to Perspective Workflow’s subscriber list. 

Note: Subscriber linking is dynamic; in other words, updates to your Perspective user records will 

automatically be reflected in your Perspective Workflow subscriber list. 

For more information on subscriber configuration, please refer to the Subscriber Maintenance 

section of the Perspective Workflow User’s Guide. 

Manually Creating a Subscriber 

1. In Perspective Workflow Event Manager, expand the Subscribers node and select Users. 

  

2. Click the New Group button in the top-left corner of the window. 
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3. Enter a Description for your group; then click OK. 

 

4. Select your new group under the Users node, and click the New User button. 
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5. Complete the Last Name and First Name fields, and check the Active box. (The Full 

Name field will automatically populate.) 

 

6. Select the Email tab, specify the subscriber’s primary email address in Email Address 1 

and, if applicable, enter their secondary email address in Email Address 2. 

7. Indicate which email address (1 or 2) should be used on various days of the week and times 

of day to notify the subscriber of an event’s occurrence. To indicate that both addresses 

should be used in a given time slot, enter an asterisk (*), or you may leave the slot blank to 

indicate that neither email address should be used. Alternatively, you can click the Use 

Address 1 for All, Use Address 2 for All, or Use Both for All buttons to quickly apply 

settings to all time slots. 
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8. IM Setup for Subscriber: Select the Instant Message tab, select the Instant Message 

Service Provider, and finally, select the IM Username of the subscriber (the person who will 

be receiving the IM notifications). 
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9. Click Save and Close. 

10. Continue to apply these steps to manually create additional subscribers as needed. 
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Linking a Subscriber Group 

1. In the Perspective Workflow Event Manager, select one of the default groups under 

Subscribers > Users (i.e., Perspective Users, Perspective Supervisors or Perspective 

Users). Then, click the Properties button at the top of the window.  

  

2. Click the Subscriber Linking button. 
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3. Click the Select Query button. 

 

4. Select the Standard Event Pak - Admin application from the list by clicking on the arrow to 

the left of the name; then click the Select button. 
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5. Select Admin – All Users with Primary Email. 

6. Then, click the Select button.  
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7. In the Linked to Database Field column on the right, select only the values shown in the 

following screenshot and click OK; then, click OK again. 

 

Note: This will link only to each subscriber’s primary email address in Perspective (the email 

address that appears in the subscriber’s Person record with the Primary box checked.) 
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Application Creation  
Before using any of the events in your Perspective Workflow Event Pak, you must complete the 

following steps: 

1. Select Application Events. 

 

2. Click New Application. 

3. A pop-up will appear telling you to name the application. Select the ODCB connection that 

was created earlier. 
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4. Click OK. 

 



Perspective Workflow Installation Guide 

38 

 

Event Configuration 
Before using any of the events in your Perspective Workflow Event Pak, you must complete the 

following steps: 

 Specify the filter values that each event’s queries will use (if applicable). 

 Run each event once using the Schedule This Now option. 

 Set each event to "Active" status. 

 Select the email account that each event’s alert messages will be sent from. 

 Ensure that each event has at least one subscriber with the Email box checked. 

 Enter a schedule for each event. 

For more information on configuring events, including designing events of your own, please refer 

to the Event Designing section of the Perspective Workflow User’s Guide. 

1. In the Perspective Workflow Event Manager, expand the Standard Event Pak - Incidents 

node and select Events. 

  

2. Double-click an event in the list on the right that meets your requirements (consult the 

Workflow Event Paks document). 
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 For this example, we are going to use Incident – Single – Incident Class ‘x’.  

 

3. Double-click the Event to open it. 

4. Click the Queries tab. 
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5. Make a note of the query it is using. 

6. Close the window. 

7. Highlight the Event and CTRL + C. 

 

8. Go to the application that you created earlier. 

9. Expand it and click Events. 
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10. Make the Description window active by clicking inside of it. 

11. Type CTRL + V to move the Event. 

 

12. Go back to Standard Event Pak Incidents. 

13. Click Query Definitions. 

14. Find the name of the query noted above. In this example, it is Incident – Incident Class ‘X’. 
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15. Highlight the Incident – New Incident and type CTRL + C. 

16. Go to the new application and click Query Definitions.  

17. Make the Description window active by clicking inside of it. 

18. Type CTRL + V to move the Query. 

 

19. Go back to the new application events. 

20. Double-click the Incident – Single – Incident Class ‘X’. 
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21. In the Description tab, check the Active box. 

22. Click the Query’s tab. Note: Where Application still has Standard Event Pak. 
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23. Click the Remove All Queries button. 

24. Click New Query. 

 

25. Select Incident – New Incident Query. 
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26. Click Select. Note: The application changes. 

 

27. If there is an ‘X’ in the name, you can enter a parameter in the Event Trigger Parameters 

field by clicking the ellipsis and selecting a value, or entering it directly in the text field. 

Note: Only values that have been saved in at least one record in your database will be 

available for selection using the Browse (…) button. If you wish to specify a filter value that 

is not available, you must type it in the Answer field. 
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28. Select the Email tab, and choose an option for the Email Account to Send From field. 

(This indicates the account that all email alert messages for this event will be sent from.) 

 

29. Feel free to edit the message subject, but do not edit text enclosed in curly brackets, such 

as {AccessLevel}. This text will be automatically replaced by data drawn from the specific 

record(s) triggering the event. 

Note: If you have someone who knows HTML, have someone edit the Message Text but do 

not alter the curly brackets. 

30. Select the Subscribers tab, and then select the Standard sub-tab. 
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31. Click Add Subscriber. 
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32. Select the users who will be receiving this e-mail. 

33. Click Add Subscriber.  
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34. Select the Schedule tab. 
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a. Select an option for the Choose a schedule to use field (e.g., Every Hour, Every 

Monday at 9:00 AM, etc.). 

 

 

OR 

b. Click the Create New Schedule button. 

i. In the Schedule field, enter a description for your new schedule. 

ii. In the Should not run until after date/time field, enter a future date when events 

using this schedule will begin to run, or leave the field blank if you want the 

schedule to be activated immediately. 

iii. In the Frequency field, choose an option for the schedule’s rate of recurrence (e.g., 

Every n Minutes, Daily, Weekly, etc.); then, in the new field that appears below, 
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specify additional details for the frequency, such as the time of day for the event to 

run or the day of the week. 
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iv. Under the Allowed Range tab, specify the months of the year, days of the week 

and hours of the day that the event is eligible to run. (Times are inclusive.) 

 

 

v. Click Save and Close. 
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35. Click Save and Close. The event is now activated and will run according to the specified 

schedule alerting the subscribers indicated. 

 

36. Continue to apply these steps to all events you would like to activate. 

Note: Please make sure you close any Workflow modules at the end of the day so that Workflow 

can do its nightly scheduled maintenance.  
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Contact Information 

Technical Support 

Toll Free:   1-877-776-2995 

Phone:    (780) 448-0616 

Email:    support@ppm2000.com 

PPM 2000 

Toll Free:   1-888-PPM-9PPM (1-888-776-9776)  

Phone:    (780) 448-0616 

Fax:    (780) 448-0618 

Email:    information@ppm2000.com 

Website:   www.ppm2000.com 

 

 


