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Welcome to Perspective Connect 

About Perspective Connect 

Perspective Connect, a companion service to Perspective Integration Services, is used to 

streamline the integration of devices and their event data. By using Perspective Connect with 

"Connectors" to supported external systems, you can configure integrations to feed data to 

Perspective—either the Activities Data Form or the DispatchLog module—out of the box and 

without extensive custom development work. 

Perspective Connect includes an easy-to-use Configuration Manager that allows you to create 

mappings for each Connector added to the system. Perspective Connect will pull information 

from the mapped devices (based on the events being monitored) then send that data to 

Perspective using pre-configured mapping. When that data is sent to DispatchLog, your 

dispatcher can determine the appropriate response. If the data is sent to a Perspective Activity, it’s 

available to all of Perspective's incident management and reporting features. 

The Perspective Connect Service and Configuration Manger are included with Perspective, but do 

require one or more Connectors to be purchased before integrating with external systems. 
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Once a Connector is integrated, its connection configuration tab will be added to Perspective 

Connect. Connectors are designed specifically for systems with multiple devices and events raised 

by those devices. 

For example, access control devices can raise events for persons granted access, persons denied 

access, or forced entry incidents, or video systems can create events such as motion detected, 

signal lost, and unattended package detected. Each of these events can be mapped with the 

appropriate location and category/priority.  

Though Perspective Connect works with both On Premise and Hosted Perspective instances, the 

Perspective Connect Service itself must be installed within the environment of the third-party 

application that will connect with Perspective. 

The Perspective Connect 1.3 installer includes: 

 AMAG SMS 

 

 Avigilon 

 

 CCure9000 

 

 Code Blue 

 

 Genetec 

 

 Honeywell Enterprise Buildings Integrator (EBI) 

 

 Lenel OnGuard 

 

 Milestone 

 

 Pelco 

Note: Each connector requires individual installation and configuration after Perspective Connect 

has been installed.  

Connectors 

AMAG Symmetry 

AMAG integrates Perspective and AMAG Symmetry with AMAG's XML Open Integration Module. 

Using the connector, AMAG Symmetry events are automatically sent to Perspective, leading to 

faster, more efficient emergency response, and reduced manual data entry. 

When an actionable event is triggered in AMAG Symmetry, the connector picks it up and 

automatically handles the event depending on how the Perspective Connect Configuration 



Connect Installation and Configuration Guide  Welcome 

 © Resolver Inc. Confidential. Do not distribute. Page 3 of 28 

 

Manager is set up. Each Symmetry event type can be sent to either an Activity form in Perspective 

or to a DispatchLog event for immediate action. 

With AMAG Symmetry you can: 

 Set the account and connection information to AMAG Service to capture AMAG alarms 

from Perspective Connect. 

 Create Perspective Activities or DispatchLog requests. 

 Map the location of AMAG Alarm Point Devices. 

 Use data captured from each system to generate Activity Reports and Incident Reports 

used for statistical analysis. 

Resolver has partnered with AMAG in Incident Reporting and Alarm Management Integrations 

and our AMAG Symmetry Connector has received AMAG factory certification  

Avigilon 

Avigilon integrates Perspective and the Avigilon Control Center 5 client, along with its monitoring 

and security features. Security hardware can be configured using Avigilon Control Center 5, which 

may be linked to Perspective Connect. As a result, detected events, such as camera motions, will 

integrate with Connect to create an Activity in Perspective. 

CCure9000 by Software House 

CCure9000 integrates Perspective and the CCure9000 Connected Program Kit. This allows for a 

variety of hardware events to be monitored, such as keypad, door open, and camera events. 

When such an event is triggered, the Perspective Connect integration can create an Activity or 

Dispatch within Perspective. 

Code Blue 

Code Blue integrates Perspective and Code Blue call stations through Code Blue's ToolVox. Using 

the connector, Code Blue calls are automatically logged into Perspective, leading to faster, more 

efficient emergency response, and reduced manual data entry. 

When a call station event is triggered in Code Blue, the connector picks it up and automatically 

handles the event depending on how the Perspective Connect Configuration Manager is set up. 

Each Code Blue event type, such as dial, hang-up, and link, can be sent to either an Activity form 

in Perspective or to a DispatchLog event for immediate action. 

Genetec 
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Genetec integrates Perspective and the Security Center along with its monitoring and security 

features. Security hardware may be configured using the Security Center, which may be linked to 

Perspective Connect. As a result, detected events, such as camera motions, will integrate with 

Connect to create an Activity in Perspective. 

Honeywell 

The Honeywell connector allows for a variety of hardware events to be monitored, such as 

keypad, door open, and camera events. When such an event is triggered, the Perspective Connect 

integration can create an Activity or Dispatch within Perspective. 

Lenel OnGuard 

The Lenel OnGuard Connector integrates Perspective and the OnGuard Data Conduit. Using the 

connector, OnGuard events are automatically sent to Perspective, leading to faster, more efficient 

emergency response, and reduced manual data entry. 

When an actionable event is triggered in OnGuard, the connector picks it up and automatically 

handles the event depending on how the Perspective Connect Configuration Manager is set up. 

Each OnGuard event type—including subtypes—can be sent to either an Activity form in 

Perspective or to a DispatchLog event for immediate action.  

Resolver is a member of the Lenel OpenAccess Alliance Program (OAAP) and Perspective’s Lenel 

OnGuard Connector has received Lenel factory certification. Please contact your account manager 

for pricing information. 

Milestone 

Milestone integrates Perspective and XProtect, along with its monitoring and security features. 

Security hardware can be configured using XProtect and then linked to Perspective Connect. As a 

result, detected events, such as camera motions, will integrate with Connect to create an Activity 

in Perspective. 

Pelco 

Pelco integrates Perspective and the Security Center along with its monitoring and security 

features. Security hardware can be configured using the Security Center, which can then be linked 

to Perspective Connect. As a result, detected events, such as camera motions, will integrate with 

Connect to create an Activity in Perspective. 

Additional Connectors 

Additional Connectors are currently in development for a variety of third-party systems.  
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Prerequisites 

Perspective Connect 

 Perspective Version 3.3 or better. (Automatically met with Perspective Hosted.) 

 Perspective Integration Services 3.3 R2 or better. (Automatically met with Perspective 

Hosted.) 

 Microsoft .NET Framework 4.0.  

 If using Perspective DispatchLog, DispatchLog Call Category Rollup items mapped to 

device events must have a default Priority specified in Perspective Administration. 

Connector: AMAG SMS 

 AMAG Symmetry SMS and smsXMLWebService Version 7.0.1. 

Connector: Avigilon 

 Avigilon Control Center 5 Client. 

Connector: CCure9000 

 Software House CCure9000 Connected Program Kit Version 2.30. 

 Software House Connected CC9000-PERSPEC license  

Connector: Code Blue 

 EMS API Version 1.1 or ToolBox greater than Version 2.0. 

Connector: Genetec 

 Security Center Version 5.2 

 SDK connection license from Genetec, part # GSC-1SDK-PPM-Perspective 
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Connector: Honeywell 

 Please contact a Resolver representative for requirements on this specific integration.  

Connector: Lenel OnGuard 

 Lenel OnGuard 2010 or Lenel OnGuard 2013 SP1, Version 6.5, 6.6, 7.0, or 7.1 

 The OnGuard DataConduIT Service must be running. 

Connector: Milestone 

 Milestone XProtect 2014 

Connector: Pelco 

 Please contact a Resolver representative for requirements on this specific integration. 
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Installation and Configuration 

Note: Installation files for On Premise installations can be obtained by Resolver. Please contact 

Technical Support at 1-877-776-2995 for additional details.  

Note: Follow the Perspective Connect installation and configuration instructions before installing 

connectors. 

Perspective Connect 

1. Install Perspective Connect: 

a. Run PerspectiveConnect.msi from your Perspective Connect installation package. 

 

b. Select Next 
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c. Select Configuration Manager and Connect Service. 

d. Select Next. 

 

e. Enter your Database Connect String. Replace DBServer with your database server and 

DB with the database to connect to.  
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SQL login credentials may be added to the Database Connection String using the 

following format: 

 

Data Source=[your sql server];Initial Catalog=[your sql database];User ID=[your sql 

user name];Password=[your sql password] 

 

f. Change the installation location as needed and select Next. 
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g. Select Next. 

 

h. Wait for installation to complete, then click Close. 

 

2. Setup the Perspective Connect database. Using a SQL query tool (e.g., Microsoft SQL Server 

Management Studio), execute update.sql against an existing database. This file can be 

found in the path where Perspective Connect was installed. 
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3. Configure the connection to Perspective Integration Services: 

a. In Windows Explorer, navigate to C:\PPM 2000 Inc\Perspective Connect. By default, 

the install files will be sorted as shown below: 

 

b. To install a Perspective Connector, extract the contents of the subfolder into the root 

folder. For example, to install AMAG, copy all of the files/folders located at C:\PPM 

2000 Inc\Perspective Connect\AmagPreReq and paste them to C:\PPM 2000 

Inc\Perspective Connect. 

Note: The license module for each connector being used must be available on Perspective 

Services. 

Note: The Perspective Connector must be installed in order to configure the Perspective 

Configuration Manager. 

c. Open ConfiugrationManager.exe. 

d. Select the Perspective Settings tab. 

e. Fill in the settings values. 
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f. Click Refresh Connection. 

Note: Services URL should be set to the URL for Integration Services. 

 

4. To log into Perspective Connect under the Local Service account: 

a. Open Administrative Tools > Services. 

b. In the list of services, right-click Perspective Connect. 

c. Select Properties. 

d. Select the Log On tab. 

e. Enter the username and password of your local/domain Windows account. 

f. Select the General tab. 

g. Select Start if the services are stopped. 

h. Click OK. 
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Connector: AMAG SMS 

1. Ensure the XML Symmetry Service is installed and running. 

Note: If the Symmetry indicator shield on the system tray is green, the service is ready for 

Perspective Connect. 

2. Configure the connection to AMAG SMS and create device/event mappings: 

a. Run the Perspective Connect Configuration Manager. 

b. On the AMAG tab and Settings sub-tab, fill in all of the settings values:  

I. Set the WebServiceUrl to http://<Server 

Name>/smsXMLWebService/smsXMLWebService.asmx. 

II. Enter a WebServiceUsername and WebServicePassword for an account with 

access to Symmetry alarms.  

 

c. On the Mapping sub-tab, create device/event mappings as required. 

d. Click Refresh Connection.  
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e. Use the Devices list and the Site, Building, Location, and Section drop-down lists to 

select the devices to monitor and then map to the corresponding site. 

f. Use the Events list and the Level 1, Level 2, and Level 3 drop-down lists to determine 

the Activity Call Category to send to Perspective. 

g. Use the Send to Perspective Activities or Send to Perspective DispatchLog radio 

buttons to determine whether the mapped device/event combination will create an 

Activity record in Perspective Data Forms or a DispatchLog Activity requiring a response. 

Note: Mapped Perspective Call Categories must have an associated Default Priority 

specified in Perspective Administration. 

h. Click File > Save. 

3. Restart the Perspective Connect Windows service. 

 

Connector: Avigilon 

1. Ensure the Avigilon Control Center 5 Client is installed and running. 
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2. Configure the connection to Avigilon and create device/event mappings: 

a. Run Perspective Connect Configuration Manager. 

b. On the Avigilon tab and Settings sub-tab, fill in all of the settings values. 

c. Click Refresh Connection. 

 

 

d. Use the Devices list and the Site, Building, Location, and Section drop-down lists to 

select the devices to monitor and then map to the corresponding site. 

e. Use the Events list and the Level 1, Level 2, and Level 3 drop-down lists to determine 

the Activity Call Category to send to Perspective. 

f. Use the Send to Perspective Activities or Send to Perspective DispatchLog radio 

buttons to determine whether the mapped device/event combination will create an 

Activity record in Perspective Data Forms or a DispatchLog Activity requiring a response. 

Note: Mapped Perspective Call Categories must have an associated Default Priority 

specified in Perspective Administration. 

g. Click File > Save. 
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3. Restart the Perspective Connect Windows service. 

Connector: CCure9000 

1. Ensure the CCure9000 Connected Program Kit is installed and running. 

2. Configure the connection to CCure9000 and create device/event mappings: 

a. Run Perspective Connect Configuration Manager. 

b. On the CCure 9000 tab and Settings sub-tab, note that there are no settings values. 

Perspective Connect should be installed on the same server as the CCure9000 

Connected Program Kit. A direct pipe is used to communicate between the programs. 

 

c. Use the Devices list and the Site, Building, Location, and Section drop-down lists to 

select the devices to monitor and then map to the corresponding site. 

d. Use the Events list and the Level 1, Level 2, and Level 3 drop-down lists to determine 

the Activity Call Category to send to Perspective. 
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e. Use the Send to Perspective Activities or Send to Perspective DispatchLog radio 

buttons to determine whether the mapped device/event combination will create an 

Activity record in Perspective Data Forms or a DispatchLog Activity requiring a response. 

Note: Mapped Perspective Call Categories must have an associated Default Priority 

specified in Perspective Administration. 

f. Click File > Save. 

3. Restart the Perspective Connect Windows service. 

Connector: Code Blue 

Note: Code Blue only works on SIP phones. 

1. Ensure the DataConduIT service is enabled.  

2. Configure the connection to CodeBlue and create device/event mappings: 

a. Run Perspective Connect Configuration Manager. 

b. On the Code Blue tab and Settings sub-tab, fill in all of the settings values.  

I. ToolVoxHostName: Enter the host name of the ToolVox Server. 

II. ToolVoxUsername and ToolVoxPassword: Enter the username and password 

for an account that has access to ToolVox services. 

III. ListeningHttpPath: Enter <Connect Host Name>/<an identifiable unique string> 

IV. ListeningHttpPort: Must be a port that ToolVox can communicate with in the 

Perspective Connect Host. The Host machine must have the corresponding port 

firewall open. 

Note: The Path in ListeningHttpPath and ListeningHttpPort must be the same as in 

Toolvox EMS API Settings. 

c. Click Refresh Connection.  
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d. On the Code Blue tab and Mapping sub-tab, create device/event mappings as 

required: 
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i. Use the Devices list and the Site, Building, Location, and Section drop-down 

lists to specify the devices to monitor and map to the corresponding site. 

ii. Use the Events list and the Level 1, Level 2, and Level 3 drop-down lists to 

determine the Activity Call Category to send to Perspective. 

iii. Use the Send to Perspective Activities or Send to Perspective DispatchLog 

radio buttons to determine whether the mapped device/event combination will 

create an Activity record in Perspective Data Forms or a DispatchLog Activity 

requiring a response. 

Note: Mapped Perspective Call Categories must have an associated Default Priority 

specified in Perspective Administration 

e. Click File > Save. 

3. Restart the Perspective Connect Windows service. 

Connector: Genetec 

1. Ensure the Genetec Security Center is installed and running. 

2. Configure the connection to Genetec and create device/event mappings: 

a. Run Perspective Connect Configuration Manager. 

b. On the GenetecServer tab and Settings sub-tab, fill in all of the settings values.  

c. Click Refresh Connection. 
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d. Use the Devices list and the Site, Building, Location, and Section drop-down lists to 

specify the devices to monitor and map to the corresponding site. 

e. Use the Events list and the Level 1, Level 2, and Level 3 drop-down lists to determine 

the Activity Call Category to send to Perspective. 

f. Use the Send to Perspective Activities or Send to Perspective DispatchLog radio 

buttons to determine whether the mapped device/event combination will create an 

Activity record in Perspective Data Forms or a DispatchLog Activity requiring a response. 

Note: Mapped Perspective Call Categories must have an associated Default Priority 

specified in Perspective Administration 

g. Click File > Save. 

3. Restart the Perspective Connect Windows service. 

Connector: Honeywell 

1. Ensure the Honeywell program is installed and running. 

2. Configure the connection to Honeywell and create device/event mappings: 
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a. Run Perspective Connect Configuration Manager. 

b. On the Honeywell tab and Settings sub-tab, fill in all of the settings values. 

c. Click Refresh Connection 

d. Use the Devices list and the Site, Building, Location, and Section drop-down lists to 

specify the devices to monitor and map to the corresponding site. 

e. Use the Events list and the Level 1, Level 2, and Level 3 drop-down lists to determine 

the Activity Call Category to send to Perspective. 

f. Use the Send to Perspective Activities or Send to Perspective DispatchLog radio 

buttons to determine whether the mapped device/event combination will create an 

Activity record in Perspective Data Forms or a DispatchLog Activity requiring a response. 

Note: Mapped Perspective Call Categories must have an associated Default Priority 

specified in Perspective Administration 

g. Click File > Save. 

3. Restart the Perspective Connect Windows service. 

Connector: Lenel OnGuard 

1. Ensure the DataConduIT service is enabled. For more information, see “Enabling the Lenel 

OnGuard DataConduIT Service.” 

2. Configure a Windows account that will be used to connect to OnGuard. The account must 

have the Enable Account and Execute Methods permissions to the root\OnGuard WMI 

namespace hosted on the OnGuard server. Refer to the Microsoft Support article on this 

subject for further instructions. 

3. Configure an OnGuard account to connect to Perspective: 

a. Assign a Systems Permissions Group that has the DataConduIT Service permission to 

the OnGuard account. 

b. Create a directory in OnGuard that refers to the location of the Windows account (as 

configured in step 2). Refer to the Add a Directory section in the Directories Folder 

chapter of the OnGuard System Administration User Guide for further instructions. 

c. Link the account to the Windows account. Refer to the Link a User Account to a Directory 

Account in the OnGuard System Administration User Guide for further instructions. 

4. Configure the connection to OnGuard and create device/event mappings: 

http://support.microsoft.com/kb/325353
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a. Run Perspective Connect Configuration Manager. 

b. On the OnGuard tab and Settings sub-tab, fill in the settings values. 

i. If UseProcessIdentity is set to true, the connection to OnGuard will use the 

credentials of the current identity running on the process. 

ii. If UseProcessIdentity is set to false, the connection to OnGuard will use the 

credentials specified by the Username and Password settings. 

iii. If the Perspective Connect Service or Perspective Connect Configuration Manager 

is running on the same machine as the OnGuard server, you must set 

UseProcessIdentity to true. 

iv. Set Auto-Acknowledge Event to true to have Connect acknowledge events in 

OnGuard that are mapped to Perspective. Set to false if you wish to manually 

acknowledge these events in OnGuard. 

c. Click Refresh Connection.  

d. On the OnGuard tab and Mapping sub-tab, create device/event mappings as required. 

 

i. Use the Devices list and the Site, Building, Location, and Section drop-down 

lists to specify the devices to monitor and map to the corresponding site. 
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ii. Use the Events list and the Level 1, Level 2, and Level 3 drop-down lists to 

determine the Activity Call Category to send to Perspective. 

iii. Use the Send to Perspective Activities or Send to Perspective DispatchLog 

radio buttons to determine whether the mapped device/event combination will 

create an Activity record in Perspective Data Forms or a DispatchLog Activity 

requiring a response. 

Note: Mapped Perspective Call Categories must have an associated Default Priority 

specified in Perspective Administration. 

e. Click File > Save. 

5. Restart the Perspective Connect Windows service. 

Connector: Milestone 

1. Ensure Milestone XProtect is installed and running. 

2. Configure the connection to Milestone and create device/event mappings: 

a. Run Perspective Connect Configuration Manager. 

b. On the Milestone tab and Settings sub-tab, fill in the settings values. 

c. Click Refresh Connection. 
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d. Use the Devices list and the Site, Building, Location, and Section drop-down lists to 

specify the devices to monitor and map to the corresponding site. 

e. Use the Events list and the Level 1, Level 2, and Level 3 drop-down lists to determine 

the Activity Call Category to send to Perspective. 

f. Use the Send to Perspective Activities or Send to Perspective DispatchLog radio 

buttons to determine whether the mapped device/event combination will create an 

Activity record in Perspective Data Forms or a DispatchLog Activity requiring a response. 

Note: Mapped Perspective Call Categories must have an associated Default Priority 

specified in Perspective Administration. 

g. Click File > Save. 

3. Restart the Perspective Connect Windows service. 

Connector: Pelco 

1. Ensure the Pelco program is installed and running. 

2. Configure the connection to Pelco and create device/event mappings: 
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a. Run Perspective Connect Configuration Manager. 

b. On the Pelco tab and Settings sub-tab, fill in the settings values. 

c. Click Refresh Connection 

d. Use the Devices list and the Site, Building, Location, and Section drop-down lists to 

specify the devices to monitor and map to the corresponding site. 

e. Use the Events list and the Level 1, Level 2, and Level 3 drop-down lists to determine 

the Activity Call Category to send to Perspective. 

f. Use the Send to Perspective Activities or Send to Perspective DispatchLog radio 

buttons to determine whether the mapped device/event combination will create an 

Activity record in Perspective Data Forms or a DispatchLog Activity requiring a response. 

Note: Mapped Perspective Call Categories must have an associated Default Priority 

specified in Perspective Administration 

g. Click File > Save. 

3. Restart the Perspective Connect Windows service.
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Tips and Additional Information 

Enabling the Lenel OnGuard DataConduIT Service 

To enable Lenel OnGuard's DataConduIT Service: 

1. Open OnGuard System Administration. 

2. Click Administration > System Options. 

3. In the General Systems Options tab, ensure that Generate software events is checked. 

4. On the server running OnGuard, click on the Windows Start menu, click on All Programs > 

Administrative Tools > Services. 

5. Ensure the following has a Status set to Started and Startup Type set to Automatic: 

a. LS DataConduIT Service. 

b. LS License Server. 

c. LS Linkage Server. 

d. LS Login Driver. 

6. On the server running OnGuard, enable the Windows Management Instrumentation 

(WMI-In) Inbound Rule in the Windows Firewall. 

Configuring RPC Connections 
1. You may need to open your firewall to allow RPC connections. For more information, view the 

“To create a rule to allow inbound network traffic to RPC-enabled network services” section of 

this Microsoft article. 

 

2. Ensure the Windows service Remote Procedure Call (RPC) is running. 

 

3. Grant the necessary permissions to the user account that will run the Connect service, under 

COM Security.  

 

a. Launch the Component Services administrative tool. 

 

b. Navigate to Console Root > Component Services > Computers > My Computer. 

 

c. Right-click on My Computer.  

https://technet.microsoft.com/en-us/library/cc947809(v=ws.10).aspx
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d. Click Properties > COM Security tab. 

 

e. For both Access Permissions and Launch and Activation Permissions, click Edit 

Default, and select Allow for all permissions for the desired user.
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Contact Information 

Technical Support 
Toll Free:   1-877-776-2995 

Phone:    (780) 448-0616 

Email:    support@resolver.com 

Website:   https://support.resolver.com  

Resolver Inc. 

Toll Free:   1-888-776-9776 

Phone:    (780) 448-0616 

Fax:    (780) 448-0618 

Email:    information@resolver.com 

Web Site:   http://www.resolver.com 

mailto:support@resolver.com
https://support.resolver.com/
mailto:information@resolver.com
http://www.resolver.com/

