Logo
My activities
Submit a Ticket >

Toll Free: 1.877.776.2995

Resolver Core System Requirements

Resolver Core runs on the following Internet browsers:

  • The latest version of Google Chrome; or
  • Microsoft Edge (recommended) or Internet Explorer 11.

Visit the links below to download Chrome, Edge, or Internet Explorer 11 and to ensure your computer meets the minimum system requirements.

Follow
Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request
Powered by Zendesk