Logo
My activities
Submit a Ticket >

Toll Free: 1.877.776.2995

GAL System Requirements

The latest version of Global AlertLink runs on the following Internet browsers:

  • Internet Explorer 11 or Edge;
  • Google Chrome; or
  • Mozilla Firefox.

Visit the links below to download Internet Explorer 11, Chrome, or Firefox and to ensure your computer meets the minimum system requirements.

Note that each browser behaves differently. Visit HTML 5 Test for more information on browser compatibility.

Due to changing environments, Global AlertLink only supports TLS (Transport Layer Security) 1.2. If your browser is not compliant with TLS 1.2, you will not be able to access Global AlertLink.

Follow
Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request
Powered by Zendesk